Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Bug?? Can't Remove Folder
#1
Question 
I had imported a series of folders (one per year of photographic work) into Foto.

Years 2007-2021 had some Ratings assigned by previous photo manager software (such as Bridge).  When these folders were imported the exif data was read and their star ratings appeared in Foto (hooray!).

2022 I imported before I had rated it.

I then used Bridge to set star ratings for the photos in 2022.

When I opened that folder again with Foto, it did not see the new exif data (no stars for any images in 2022).

I tried Synchronise, and it did not recognise that any files were altered (though the exif header data had been edited by Bridge).  0 changes, so 0 updates to the database.

I then tried to Remove the 2022 folder from Foto, using the popup menu on the folder name, hoping that I could import it again and that would force Foto to re-read the altered exif data.

When I tried to Remove the folder, Foto grabbed 100 pct of the CPU and said it was 0 percent done with removal.... apparently forever (no progress).  It just sits there at 0% doing who knows what... Since it is only deleting database info I would have expected it to be fairly quick.  But it hangs.  (Apparently... I will next try leaving it to run overnight).

Trying to cancel this Remove operation also hangs.  Quitting the app gets me a warning that I might corrupt the database, but I have little option as the app is now hanging trying to do the Remove.

I have Quit and restarted a couple of times but I cannot get Foto to re-read the exif data of images it already imported.   Angry

help??
#2
Hi Tazling,

if the problem persists, please send us an error report to our support by clicking Help -> Send error report... in the Excire Foto menu.
This will send us the program log files that we need for error analysis.

Thanks!
#3
Well, I let it run overnight and eventually the delete happened and I was able to proceed. It seems like Delete Folder is a very slow operation, this might be worth looking at.

Also it seems like there should be an option to Re-Scan EXIF Data for folders that are already imported, so you don't have to go through the Delete and re-import process...

But I've got past the glitch and am back in business curating photos for a new calendar project.
#4
I'm glad to hear it worked in the end.

For your information and those that read this post later:
With the latest update of Excire Foto 2022, the performance when deleting images on network drives (NAS) has been increased.

Make sure you have the latest version installed.


Gehe zu: